Updated Debian 8: 8.4 released

April 2nd, 2016

The Debian project is pleased to announce the fourth update of its stable distribution Debian 8 (codename jessie ). This update mainly adds corrections for security problems to the stable release, along with a few adjustments for serious problems. Security advisories were already published separately and are referenced where available.

Please note that this update does not constitute a new version of Debian 8 but only updates some of the packages included. There is no need to throw away old jessie CDs or DVDs but only to update via an up-to-date Debian mirror after an installation, to cause any out of date packages to be updated.

Those who frequently install updates from security.debian.org won’t have to update many packages and most updates from security.debian.org are included in this update.

New installation media and CD and DVD images containing updated packages will be available soon at the regular locations.

Upgrading to this revision online is usually done by pointing the aptitude (or apt) package tool (see the sources.list(5) manual page) to one of Debian’s many FTP or HTTP mirrors. A comprehensive list of mirrors is available at:


Miscellaneous Bugfixes

This stable update adds a few important corrections to the following packages:

Package Reason
amavisd-new Set LC_ALL before running daemon
amd64-microcode Update AMD microcode patch firmware for AMD Family 15h Processors to fix bugs in prior microcode patch
apt apt-pkg/algorithms.cc: Avoid stack buffer overflow in KillList
aptdaemon Security fix [CVE-2015-1323]
ardour Repack to remove libs/pdb/dmalloc.cc
base-files Update for the point release
c-icap-modules Rebuild against libclamav7
cairo Security fix [CVE-2016-3190]
cinnamon-settings-daemon Fix a minor security bug (missing polkit check)
clamav New upstream version; avoid unaligned memory access
conkeror Fix matching of module load error messages to work with Firefox 36
dansguardian Rebuild against libclamav7
debian-installer Rebuild against proposed-updates
debian-installer-netboot-images Rebuild against new debian-installer
dolibarr Multiple security fixes [CVE-2015-3935 CVE-2015-8685 CVE-2016-1912]
espeakup Make looking up available languages independent from file hierarchy; use Portuguese for Galician; synth.c: Fix looking up voices by language name
exactimage Security fix [CVE-2015-8366]
fglrx-driver libfglrx-amdxvba1: add Breaks+Replaces: xvba-va-driver (<< 0.8.0-9+deb) since we now ship fglrx_drv_video.so and xvba_drv_video.so
flash-kernel Use /dev/mtdN when flashing, rather than needlessly going through the mtdblock layer (which is problematic on some platforms/kernels); use nandwrite when writing to nand flash
fonts-sil-andika Really remove 65-andika.conf
giflib Bail out if Width > SWidth [CVE-2015-7555]
glib2.0 Rebuild against updated pcre3 to pull in security updates
glibc Improve granpt when /dev/pts is not mounted with the correct options; don’t build pt_chown [CVE-2013-2207]
gnome-shell-extension-weather New upstream snapshot, compatible with the new API of openweathermap.org
gnupg Correctly handle unknown subkey types
gtk+2.0 Avoid integer overflow when allocating a large block of memory [CVE-2013-7447]
gummi Update fix for predictable temporary filenames [CVE-2015-7758] to use upstream’s fix
havp Rebuild against libclamav7
imagemagick Security fixes
initramfs-tools Add missing drivers and various bugfixes
installation-guide Add QNAP TS-109, TS-209, TS-409 and TS-409U as supported models again
libclamunrar Rebuild for libclamav7
libdatetime-timezone-perl Update included timezone data to tzdata 2016c
librsvg Fix out-of-bounds heap read when parsing SVG file [CVE-2015-7557]
libsndfile Fix denial of service through division by zero [CVE-2014-9756] and heap overflow in AIFF parser [CVE-2015-7805]
libvirt Don’t allow allow ‘/’ in filesystem volume [CVE-2015-5313]; libvirt-daemon: Expect qemu-bridge-helper in /usr/lib/qemu
linux Update to new upstream release 3.16.7-ckt25; add dm-service-time to multipath-modules; add support for MIPS 5KE CPU
mongrel2 Comment out failing test caused by an expired certificate
mozilla-devscripts Update dh_xul-ext’s substvar generation for the upcoming transitions in stable from iceweasel to firefox-esr, and from icedove to thunderbird
nettle Multiple security fixes [CVE-2015-8803 CVE-2015-8804 CVE-2015-8805]
nss-pam-ldapd Fix issues with daemonising nslcd and avoid a race condition in signal handling during start-up; fix password policy expiration warnings; ensure proper return code of init script
osmo Fix corrupt data backup on i386
pagekite Add missing build dependency python-openssl to fix test failure
pam Rebuild to fix multi-arch co-installability
pcre3 Fix workspace overflow for (*ACCEPT) with deeply nested parentheses [CVE-2016-3191]; fix heap buffer overflow in handling of duplicate named groups [CVE-2016-1283]; fix an issue with nested table jumps [CVE-2014-9769]
pgplot5 Fix build failure by using multiarch path to zconf.h
php-dompdf Fix information disclosure vulnerability [CVE-2014-5011], denial of service [CVE-2014-5012] and remote code execution [CVE-2014-5013]
php-mail-mime Add missing dependency on php-pear
php-net-ldap2 Fix fatal error with newer PEAR versions
php5 New upstream stable release; revert PEAR version to last working version from PHP 5.6.14
postgresql-9.1 New upstream release
postgresql-common pg_upgradecluster: Set default dynamic_shared_memory_type = mmap; this primarily avoids problems with upgrading existing clusters in a LXC container
python-clamav Rebuild against libclamav7
python-rsa Fix possible signature forgery using Bleichenbacher’06 attack [CVE-2016-1494]
rdesktop Fix sigsegv while using credssp and Kerberos without specifying domainname as argument
rsnapshot Fix regression on –rsh with arguments
ruby-defaults ruby: make the conflict on ruby-activesupport-2.3 versioned on (<< 2:4) to allow the transitional package to be installed
ruby-standalone Install ‘rubyX.Y’ as a link to ‘ruby’ so that binaries installed by bundler work
ruby-tzinfo Load iso3166.tab and zone.tab as UTF-8
s3ql Support upgrades from file systems created with the S3QL version in Debian Wheezy
sane-backends Rewrite debian/saned@.service to prevent errors with network scanning; prevent start via fallback script /etc/init.d/saned
sitesummary Fix hanging postinst script, dangling symlink in Apache config after removal
stress Don’t install info/dir.gz
subversion Fix segfault when using kwallet to store authentication information
suckless-tools slock: make cover window resize correctly when new screens are added or the resolution is changed while the lock is active
sus Update checksum of upstream tarball
systemd Make sure all swap units are ordered before the swap target. This avoids swap devices being stopped prematurely during shutdown; only skip the filesystem check for /usr if the /run/initramfs/fsck-usr flag file exists, avoiding issues when using dracut; fix –network-interface in systemd-nspawn to not fail when modifying an existing link; don’t call addgroup with –quiet; debian/udev.prerm: Add missing deconfigure action
torbrowser-launcher Disable certificate pinning, to avoid issues with upcoming certificate change; prevent signature verification attack by passing both data file as well as sig file into gpg [CVE-2016-3180]
tzdata New upstream release
unbound Update hints for H.ROOT-SERVERS.NET
user-mode-linux Rebuild against Linux kernel 3.16.7-ckt20-1+deb8u3
vsftpd Fix config option deny_file not always being handled correctly [CVE-2015-1419]; set the default value of tunable_listen to the same value of listen from the man page vsftpd.conf
whatmaps Respect Jessie Apache package rename
xvba-video xvba-va-driver as a separate package has been obsoleted by fglrx-driver 1:15.9, turn it into an empty metapackage

Security Updates

This revision adds the following security updates to the stable release. The Security Team has already released an advisory for each of these updates:

Advisory ID Package
DSA-3426 ctdb
DSA-3447 tomcat7
DSA-3448 linux
DSA-3449 bind9
DSA-3450 ecryptfs-utils
DSA-3451 fuse
DSA-3452 claws-mail
DSA-3453 mariadb-10.0
DSA-3454 virtualbox
DSA-3455 curl
DSA-3456 chromium-browser
DSA-3457 iceweasel
DSA-3459 mysql-5.5
DSA-3460 privoxy
DSA-3462 radicale
DSA-3463 prosody
DSA-3464 rails
DSA-3466 krb5
DSA-3467 tiff
DSA-3468 polarssl
DSA-3471 qemu
DSA-3472 wordpress
DSA-3474 libgcrypt20
DSA-3477 iceweasel
DSA-3479 graphite2
DSA-3481 glibc
DSA-3483 cpio
DSA-3484 xdelta3
DSA-3485 didiwiki
DSA-3486 chromium-browser
DSA-3487 libssh2
DSA-3488 libssh
DSA-3490 websvn
DSA-3492 gajim
DSA-3493 xerces-c
DSA-3494 cacti
DSA-3496 php-horde-core
DSA-3497 php-horde
DSA-3498 drupal7
DSA-3499 pillow
DSA-3500 openssl
DSA-3501 perl
DSA-3502 roundup
DSA-3503 linux
DSA-3504 bsh
DSA-3505 wireshark
DSA-3506 libav
DSA-3507 chromium-browser
DSA-3508 jasper
DSA-3509 rails
DSA-3510 iceweasel
DSA-3511 bind9
DSA-3512 libotr
DSA-3513 chromium-browser
DSA-3514 samba
DSA-3515 graphite2
DSA-3516 wireshark
DSA-3517 exim4
DSA-3518 spip
DSA-3519 xen
DSA-3521 git
DSA-3522 squid3
DSA-3523 iceweasel
DSA-3524 activemq
DSA-3526 libmatroska
DSA-3527 inspircd
DSA-3528 pidgin-otr
DSA-3529 redmine
DSA-3531 chromium-browser
DSA-3532 quagga

Removed packages

The following packages were removed due to circumstances beyond our control:

Package Reason
gnome-gmail Broken
nautilus-pastebin Unmaintained

Debian Installer

The installer has been updated to include the fixes incorporated into stable by the point release.


The complete lists of packages that have changed with this revision:


The current stable distribution:


Proposed updates to the stable distribution:


stable distribution information (release notes, errata etc.):


Security announcements and information:


About Debian

The Debian Project is an association of Free Software developers who volunteer their time and effort in order to produce the completely free operating system Debian.

Contact Information

For further information, please visit the Debian web pages at https://www.debian.org/ , send mail to <press@debian.org>, or contact the stable release team at <debian-release@lists.debian.org>.

转载本站任何文章请注明:转载至神刀安全网,谢谢神刀安全网 » Updated Debian 8: 8.4 released

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址