神刀安全网

At this time you should not upgrade a production desktop from 14.04 to 16.04

Table of Contents

Contents

      1. Official flavour release notes
    1. Download Ubuntu 16.04 LTS
    2. Upgrading from Ubuntu 14.04 LTS or 15.10
  1. New features in 16.04 LTS
    1. Boot, installation and post-install
      1. Errors about swap partition at install
      1. 14.04 LTS to 16.04 LTS Desktop Upgrade

Introduction

These release notes for Ubuntu 16.04 LTS (Xenial Xerus) provide an overview of the release and document the known issues with Ubuntu 16.04 LTS and its flavors.

Support lifespan

Official flavour release notes

Find the links to release notes for official flavorshere.

Get Ubuntu 16.04 LTS

Download Ubuntu 16.04 LTS

Images can be downloaded from a location near you.

You can download ISOs from:

Upgrading from Ubuntu 14.04 LTS or 15.10

Please note there is a known issue when upgrading 14.04 LTS. See the Known Issues section for more information

To upgrade on a desktop system:

  • Open the "Software & Updates" Setting in System Settings.

  • Select the 3rd Tab called "Updates".
  • Set the "Notify me of a new Ubuntu version" dropdown menu to "For any new version".
  • Press Alt+F2 and type in "update-manager" (without the quotes) into the command box.
  • Update Manager should open up and tell you: New distribution release ‘16.04 LTS’ is available.
  • Click Upgrade and follow the on-screen instructions.

To upgrade on a server system:

  • Install the update-manager-core package if it is not already installed.

  • Make sure the /etc/update-manager/release-upgrades is set to normal.
  • Launch the upgrade tool with the command sudo do-release-upgrade .

  • Follow the on-screen instructions.

Note that the server upgrade will use GNU screen and automatically re-attach in case of dropped connection problems.

There are no offline upgrade options for Ubuntu Desktop and Ubuntu Server. Please ensure you have network connectivity to one of the official mirrors or to a locally accessible mirror and follow the instructions above.

New features in 16.04 LTS

Updated Packages

As with every new release, packages–applications and software of all kinds–are being updated at a rapid pace. Many of these packages came from an automatic sync from Debian ‘s unstable branch; others have been explicitly pulled in for Ubuntu 16.04.

For a list of all packages being accepted for Ubuntu 16.04, please subscribe toxenial-changes.

Linux kernel 4.4

Ubuntu 16.04 LTS is based on the long-term supported Linux release series 4.4.

Python 3.5

Python has been upgraded to the 3.5 series.

If you have your own programs based on Python 2, fear not! Python 2 will continue to be available (as the python package) for the foreseeable future. However, to best support future versions of Ubuntu you should consider porting your code to Python 3. Python/3 has some advice and resources on this.

VIM defaults to python3

The default VIM package has been built against python3 instead of python2. This means plugins that require a python2 interpreter support from VIM will not work anymore.For this case alternative VIM packages are available that still use python2, for example vim-gnome-py2.They can be made the default via the alternatives mechanism:

  • sudo update-alternatives –set vim /usr/bin/vim.gnome-py2

Golang 1.6

golang toolchain was upgraded to the 1.6 series, and gcc-go was upgraded to the GCC6 branch. Thus the same level of standard library and compiler features are provided by both compilers on all fully supported architectures.

OpenSSH 7.2p2

Recent OpenSSH releases disable several pieces of weak, legacy, and/or unsafe cryptography. If you are upgrading a system remotely over SSH, you should check that you are not relying on these to ensure that you will retain access after the upgrade.

  • Support for the legacy SSH version 1 protocol is disabled by default at compile time. Note that this also means that the Cipher keyword inssh_config(5) is effectively no longer usable; use Ciphers instead for protocol 2. Theopenssh-client-ssh1 package includes "ssh1", "scp1", and "ssh-keygen1" binaries which you can use if you have no alternative way to connect to an outdated SSH1-only server; please contact the server administrator or system vendor in such cases and ask them to upgrade.

  • Support for the 1024-bit diffie-hellman-group1-sha1 key exchange is disabled by default at run-time. It may be re-enabled using the upstream instructions .

  • Support for ssh-dss , ssh-dss-cert-* host and user keys is disabled by default at run-time. These may be re-enabled using the upstream instructions .

  • Support for the legacy v00 cert format has been removed.

  • Several ciphers are disabled by default in ssh : blowfish-cbc , cast128-cbc , all arcfour variants and the rijndael-cbc aliases for AES.

  • MD5-based and truncated HMAC algorithms are disabled by default in ssh .

docker 1.10

docker was upgraded to the version 1.10. Note that this requires migration of existing images to a new format which will be performed on the first start of the service. This migration can take a long time and put a high load on the system, see https://docs.docker.com/engine/migration/ for more information.

Ubuntu for IBM LinuxONE

Ubuntu 16.04 LTS includes a new port to 64-bit z/Architecture for IBM mainframe computers. This is a practically complete port of Ubuntu Server and Cloud with circa 95% binary package availability. We are excited to enable OpenStack software, Juju, MAAS, LXD, and much more on this platform.

Ubuntu Desktop

The general theme for 16.04 on the desktop is one of bug fixes and incremental quality improvements …

General

  • GNOME is mostly upgraded to 3.18. GLib upgraded to to 2.48 (corresponding to GNOME 3.20)
  • GNOME Software replaces Ubuntu Software Center. This brings a faster store experience and moves our archive metadata in line with Debian.
  • All default applications and libraries ported to use WebKit 2

  • GNOME Calendar is now included by default
  • Empathy and Brasero are removed from the default installation
  • Chromium upgraded to version 48
  • Firefox upgraded to version 45
  • Online searches in the dash are now disabled by default
  • Improved HiDPI support in the greeter
  • Added more supported languages by defaultMore info

  • Multiple bug fixes

Unity & Compiz

  • Improved launcher integrates with file manager and devices
  • Support for formatting removable devices from quicklist
  • Improved support for gtk applications using headerbars
  • Improvements to the switcher and spread backends
  • Activate app spread by Super+Ctrl+W
  • Unity control center option to always show menus
  • Improvements to GNOME key grabbing
  • New dash overlay scrollbars
  • Better Dash theming support
  • Support for scaling cursors in HiDPI environments
  • Show icons launching state in launcher when apps launched elsewhere
  • Launcher can be moved to the bottom

LibreOffice

LibreOffice 5.1 brings a lot of improvements to entire package. For more information on these improvements please see the LibreOffice release notes available here . You can see a video highlighting some of the new features here .

General

Writer word processor

Calc spreadsheets

  • Exponential and power trend lines handle negative Y values
  • Performance improvements leveraging SSE3 for SUM functions
  • Added support for PNG export
  • Search for numbers as formatted/displayed

Impress presentations

  • Slide transitions use OpenGL 2.1+ and new transitions added
  • Keyboard shortcuts for navigation and sorting
  • Screensaver inhibiting for KDE, XFCE, Mate

Ubuntu Server

Known issues

As is to be expected, with any release, there are some significant known bugs that users may run into with this release of Ubuntu 16.04. The ones we know about at this point (and some of the workarounds), are documented here so you don’t need to spend time reporting these bugs again:

Boot, installation and post-install

Errors about swap partition at install

There is a known issue regarding the creation of swap space during the install. In some cases the install will display the error message "Creation of swap space in Partition #n …. failed.". Please see this bug for more information. You may work around the issue by manually partitioning the disk and removing any existing swap partitions before then creating a new one.

Upgrade

14.04 LTS to 16.04 LTS Desktop Upgrade

There is a known issue which prevents the upgrade of 14.04 LTS to 16.04 LTS. Please see this bug for more information.

At this time you should not attempt to upgrade a production desktop from 14.04 LTS to 16.04 LTS.

Graphics and Display

fglrx

The fglrx driver is now deprecated in 16.04, and we recommend its open source alternatives (radeon and amdgpu). AMD put a lot of work into the drivers, and we backported kernel code from Linux 4.5 to provide a better experience.

When upgrading to Ubuntu 16.04 from a previous release, both the fglrx driver and the xorg.conf will be removed, so that the system is set to use either the amdgpu driver or the radeon driver (depending on the available hardware).

Official flavours

The release notes for the official flavours can be found at the following links:

More information

Reporting bugs

Your comments, bug reports, patches and suggestions will help fix bugs and improve the quality of future releases. Please report bugs using the tools provided .

If you want to help out with bugs, theBug Squad is always looking for help.

Participate in Ubuntu

If you would like to help shape Ubuntu, take a look at the list of ways you can participate at

More about Ubuntu

You can find out more about Ubuntu on theUbuntu website andUbuntu wiki.

To sign up for future Ubuntu development announcements, please subscribe to Ubuntu’s development announcement list at:

转载本站任何文章请注明:转载至神刀安全网,谢谢神刀安全网 » At this time you should not upgrade a production desktop from 14.04 to 16.04

分享到:更多 ()

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址
分享按钮