漏洞详情

披露状态:

2014-02-26: 细节已通知厂商并且等待厂商处理中
2014-02-28: 厂商已经确认,细节仅向厂商公开
2014-03-10: 细节向核心白帽子及相关领域专家公开
2014-03-20: 细节向普通白帽子公开
2014-03-30: 细节向实习白帽子公开
2014-04-12: 细节向公众公开

简要描述:

安踏商城文件包含漏洞

详细说明:

在测试安全问题的时候,发现了某处存在文件包含漏洞,而且权限很高为root权限。

首先确定环境。大小写法。

www.anta.com/index.php正常访问。

www.anta.com/indeX.php提示文件不存在。

确定系统为linux。

如果存在文件包含,则可能读取/etc/password(如果权限够)。



经排查,发现一处文件包含漏洞,并且权限为root权限。



TM截图20140226191558.png

漏洞证明:

同上

修复方案:

PHP页面:

REQUEST["app_page"]=preg_replace("\.\.","",REQUEST["app_page"]);



=========

只是我最省事的写法。

还请专业人士改进!

版权声明:转载请注明来源 乌云@乌云


漏洞回应

厂商回应:

危害等级:中

漏洞Rank:8

确认时间:2014-02-28 09:10

厂商回复:

感谢您关注安踏的信息安全,问题修复中。

最新状态:

暂无


漏洞评价: