搜狗通行证服务器运维不当导致信息泄露

漏洞详情

披露状态:

2014-04-08: 细节已通知厂商并且等待厂商处理中
2014-04-08: 厂商已经确认,细节仅向厂商公开
2014-04-18: 细节向核心白帽子及相关领域专家公开
2014-04-28: 细节向普通白帽子公开
2014-05-08: 细节向实习白帽子公开
2014-05-23: 细节向公众公开

简要描述:

搜狗通行证服务器运维不当导致信服务器敏感信息泄露

详细说明:

最近爆出 openssl 的 heartbleed 漏洞,今天晚上已经有详细的文章以及利用工具了,详细的分析文章可以见下面:

https://account.sogou.com

英文原版文章

http://blog.existentialize.com/diagnosis-of-the-openssl-heartbleed-bug.html



国内翻译的中文版

http://drops.wooyun.org/papers/1381



利用脚本:

http://s3.jspenguin.org/ssltest.py





具体的危害呢就是会读取服务器上一段 64kb 大小的内存,具体的影响要看业务场景。



这里搜狗通行证可以读取到cookie的内容,所以还是很重要的。



漏洞证明:

python openssl.py account.sogou.com





11111.jpg

修复方案:

1、只影响 openssl 1.0.1 到 1.0.1f 版本,还有 openssl 1.0.2 beta 版本,其他版本不受影响,不受影响的版本不需要进行修复

2、1.0.1g 版本已经修复该漏洞,如果服务器上 openssl 版本存在该漏洞请升级到这个版本

版权声明:转载请注明来源 Fireweed@乌云


漏洞回应

厂商回应:

危害等级:高

漏洞Rank:10

确认时间:2014-04-08 19:32

厂商回复:

收到,感谢支持,我们会尽快修复的

最新状态:

暂无


漏洞评价: